use strict;
my $str = '7,673,656.87
427,870.27
7,401.38
102,393.11
2,340,692.03
2,093,675.04
';
my $regex = qr/\d+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";