import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+";
final String string = "7,673,656.87\n"
+ "427,870.27\n"
+ "7,401.38\n"
+ "102,393.11\n"
+ "2,340,692.03\n"
+ "2,093,675.04\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}