const regex = new RegExp('\\d+', 'gm')
const str = `7,673,656.87
427,870.27
7,401.38
102,393.11
2,340,692.03
2,093,675.04
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);