// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)The field \'(\w+)\' is not valid for this request type \'([a-z|A-Z|(0-9)*|\s+]*)\'").unwrap();
let string = "The field 'customfield_12583' is not valid for this request type 'Side Tasks'
The field 'customfield_22222' is not valid for this request type 'NOC'
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}