use strict;
my $str = 'The field \'customfield_12583\' is not valid for this request type \'Side Tasks\'
The field \'customfield_22222\' is not valid for this request type \'NOC\'
';
my $regex = qr/The field \'(\w+)\' is not valid for this request type \'([a-z|A-Z|(0-9)*|\s+]*)\'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}