package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)The field \'(\w+)\' is not valid for this request type \'([a-z|A-Z|(0-9)*|\s+]*)\'`)
var str = `The field 'customfield_12583' is not valid for this request type 'Side Tasks'
The field 'customfield_22222' is not valid for this request type 'NOC'
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}