import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "The field \\'(\\w+)\\' is not valid for this request type \\'([a-z|A-Z|(0-9)*|\\s+]*)\\'";
final String string = "The field 'customfield_12583' is not valid for this request type 'Side Tasks'\n\n"
+ "The field 'customfield_22222' is not valid for this request type 'NOC'\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}