re = /Android \d+; ([^;]+) Build/i
str = 'Android 13; SM-A515F Build/
Linux; Android 10; LM-K510 Build/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end