package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)Android \d+; ([^;]+) Build`)
var str = `Android 13; SM-A515F Build/
Linux; Android 10; LM-K510 Build/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}