using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Android \d+; ([^;]+) Build";
string input = @"Android 13; SM-A515F Build/
Linux; Android 10; LM-K510 Build/";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}