const regex = /Android \d+; ([^;]+) Build/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Android \\d+; ([^;]+) Build', 'gi')
const str = `Android 13; SM-A515F Build/
Linux; Android 10; LM-K510 Build/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}