import Foundation
let pattern = #"(?<=videos\/|v=|youtu\.be\/)([\w-]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://www.youtube.com/watch?v=q07SQFmL4rM
https://www.youtube.com/watch?v=q07SQFmL4yM
https://youtu.be/qT47KF5pvfw
https://youtu.be/zImHyTyYhM8?t=4s
https://www.youtube.com/watch?time_continue=4&v=zImHyTyYhM8
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)