#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=videos\/|v=|youtu\.be\/)([\w-]+)"
Local $sString = "https://www.youtube.com/watch?v=q07SQFmL4rM" & @CRLF & _
"https://www.youtube.com/watch?v=q07SQFmL4yM" & @CRLF & _
"https://youtu.be/qT47KF5pvfw" & @CRLF & _
"https://youtu.be/zImHyTyYhM8?t=4s" & @CRLF & _
"https://www.youtube.com/watch?time_continue=4&v=zImHyTyYhM8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")