import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=videos\\/|v=|youtu\\.be\\/)([\\w-]+)";
final String string = "https://www.youtube.com/watch?v=q07SQFmL4rM\n"
+ "https://www.youtube.com/watch?v=q07SQFmL4yM\n"
+ "https://youtu.be/qT47KF5pvfw\n"
+ "https://youtu.be/zImHyTyYhM8?t=4s\n"
+ "https://www.youtube.com/watch?time_continue=4&v=zImHyTyYhM8";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}