$re = '@(?<=videos\/|v=|youtu\.be\/)([\w-]+)@';
$str = 'https://www.youtube.com/watch?v=q07SQFmL4rM
https://www.youtube.com/watch?v=q07SQFmL4yM
https://youtu.be/qT47KF5pvfw
https://youtu.be/zImHyTyYhM8?t=4s
https://www.youtube.com/watch?time_continue=4&v=zImHyTyYhM8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);