import Foundation
let pattern = #"(?<doc_type>[A-Z]{1})\/(?<country>[A-Z]{2})\/(?<series_number>\w*)\/.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
P/RU/1002123456/RU/02FEB90/F/13JUN29/IVANOVA/OLGA -1IVANOVA/OLGAMRS
Psd/RsdfsU/1002123456/RU/02FEB90/F/13JUN29/IVANOVA/OLGA -1IVANOVA/OLGAMRS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)