// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<doc_type>[A-Z]{1})\/(?<country>[A-Z]{2})\/(?<series_number>\w*)\/.*").unwrap();
let string = "P/RU/1002123456/RU/02FEB90/F/13JUN29/IVANOVA/OLGA -1IVANOVA/OLGAMRS
Psd/RsdfsU/1002123456/RU/02FEB90/F/13JUN29/IVANOVA/OLGA -1IVANOVA/OLGAMRS";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}