$re = '/(?<doc_type>[A-Z]{1})\/(?<country>[A-Z]{2})\/(?<series_number>\w*)\/.*/m';
$str = 'P/RU/1002123456/RU/02FEB90/F/13JUN29/IVANOVA/OLGA -1IVANOVA/OLGAMRS
Psd/RsdfsU/1002123456/RU/02FEB90/F/13JUN29/IVANOVA/OLGA -1IVANOVA/OLGAMRS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);