#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<doc_type>[A-Z]{1})\/(?<country>[A-Z]{2})\/(?<series_number>\w*)\/.*"
Local $sString = "P/RU/1002123456/RU/02FEB90/F/13JUN29/IVANOVA/OLGA -1IVANOVA/OLGAMRS" & @CRLF & _
"Psd/RsdfsU/1002123456/RU/02FEB90/F/13JUN29/IVANOVA/OLGA -1IVANOVA/OLGAMRS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")