re = /[+-]?(((\d+\.\d*|\d*\.\d+|\d+)[+-])?((\d+\.\d*|\d*\.\d+|\d+)i|i(\d+\.\d*|\d*\.\d+|\d+)|i)|(\d+\.\d*|\d*\.\d+|\d+)?e\^(\([+-]?|[+-]?\()((\d+\.\d*|\d*\.\d+|\d+)i|i(\d+\.\d*|\d*\.\d+|\d+)|i)\))/m
str = '+5.6+7i,-.004+2.5i,6.-i,
i,e^-(5i),.02e^(-2.3i),7e^(i)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end