package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[+-]?(((\d+\.\d*|\d*\.\d+|\d+)[+-])?((\d+\.\d*|\d*\.\d+|\d+)i|i(\d+\.\d*|\d*\.\d+|\d+)|i)|(\d+\.\d*|\d*\.\d+|\d+)?e\^(\([+-]?|[+-]?\()((\d+\.\d*|\d*\.\d+|\d+)i|i(\d+\.\d*|\d*\.\d+|\d+)|i)\))`)
var str = `+5.6+7i,-.004+2.5i,6.-i,
i,e^-(5i),.02e^(-2.3i),7e^(i)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}