import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+-]?(((\\d+\\.\\d*|\\d*\\.\\d+|\\d+)[+-])?((\\d+\\.\\d*|\\d*\\.\\d+|\\d+)i|i(\\d+\\.\\d*|\\d*\\.\\d+|\\d+)|i)|(\\d+\\.\\d*|\\d*\\.\\d+|\\d+)?e\\^(\\([+-]?|[+-]?\\()((\\d+\\.\\d*|\\d*\\.\\d+|\\d+)i|i(\\d+\\.\\d*|\\d*\\.\\d+|\\d+)|i)\\))";
final String string = "+5.6+7i,-.004+2.5i,6.-i,\n"
+ "i,e^-(5i),.02e^(-2.3i),7e^(i)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}