const regex = /[+-]?(((\d+\.\d*|\d*\.\d+|\d+)[+-])?((\d+\.\d*|\d*\.\d+|\d+)i|i(\d+\.\d*|\d*\.\d+|\d+)|i)|(\d+\.\d*|\d*\.\d+|\d+)?e\^(\([+-]?|[+-]?\()((\d+\.\d*|\d*\.\d+|\d+)i|i(\d+\.\d*|\d*\.\d+|\d+)|i)\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+-]?(((\\d+\\.\\d*|\\d*\\.\\d+|\\d+)[+-])?((\\d+\\.\\d*|\\d*\\.\\d+|\\d+)i|i(\\d+\\.\\d*|\\d*\\.\\d+|\\d+)|i)|(\\d+\\.\\d*|\\d*\\.\\d+|\\d+)?e\\^(\\([+-]?|[+-]?\\()((\\d+\\.\\d*|\\d*\\.\\d+|\\d+)i|i(\\d+\\.\\d*|\\d*\\.\\d+|\\d+)|i)\\))', 'gm')
const str = `+5.6+7i,-.004+2.5i,6.-i,
i,e^-(5i),.02e^(-2.3i),7e^(i)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}