const regex = /(\r|\n){2,}((\s*\/\*\s*\W*\w.+\s*\*\/\s*)|(\s*\/\/\s*\W*\w.+\s*))(\r|\n){2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\r|\\n){2,}((\\s*\\\/\\*\\s*\\W*\\w.+\\s*\\*\\\/\\s*)|(\\s*\\\/\\\/\\s*\\W*\\w.+\\s*))(\\r|\\n){2,}', 'g')
const str = `
/*
* comments
*/
code
// comments
code
///////// &777772131@ 7877782388238274
code
/*
comments
*/
code
/*
* /// 34355 \$#%#comments
*/
code
// * comments
code
//// comments
code
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}