#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\r|\n){2,}((\s*\/\*\s*\W*\w.+\s*\*\/\s*)|(\s*\/\/\s*\W*\w.+\s*))(\r|\n){2,}"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"* comments" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"code" & @CRLF & _
"" & @CRLF & _
"// comments" & @CRLF & _
"" & @CRLF & _
"code" & @CRLF & _
"" & @CRLF & _
"///////// &777772131@ 7877782388238274" & @CRLF & _
"" & @CRLF & _
"code" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"comments" & @CRLF & _
"*/ " & @CRLF & _
"" & @CRLF & _
"code" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" /*" & @CRLF & _
" * /// 34355 $#%#comments" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"code" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// * comments " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"code" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//// comments" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"code" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")