package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\r|\n){2,}((\s*\/\*\s*\W*\w.+\s*\*\/\s*)|(\s*\/\/\s*\W*\w.+\s*))(\r|\n){2,}`)
var str = `
/*
* comments
*/
code
// comments
code
///////// &777772131@ 7877782388238274
code
/*
comments
*/
code
/*
* /// 34355 $#%#comments
*/
code
// * comments
code
//// comments
code
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}