re = /(\r|\n){2,}((\s*\/\*\s*\W*\w.+\s*\*\/\s*)|(\s*\/\/\s*\W*\w.+\s*))(\r|\n){2,}/
str = '
/*
* comments
*/
code
// comments
code
///////// &777772131@ 7877782388238274
code
/*
comments
*/
code
/*
* /// 34355 $#%#comments
*/
code
// * comments
code
//// comments
code
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end