import Foundation
let pattern = #"^[CM]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Tokyo
Jakarta
Delhi
Mumbai
Manila
Shanghai
Sao Paulo
Seoul
Mexico City
Guangzhou
Beijing
Cairo
New York
Kolkata
Moscow
Bangkok
Buenos Aires
Shenzhen
Dhaka
Lagos
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)