#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[CM]"
Local $sString = "Tokyo" & @CRLF & _
"Jakarta" & @CRLF & _
"Delhi" & @CRLF & _
"Mumbai" & @CRLF & _
"Manila" & @CRLF & _
"Shanghai" & @CRLF & _
"Sao Paulo" & @CRLF & _
"Seoul" & @CRLF & _
"Mexico City" & @CRLF & _
"Guangzhou" & @CRLF & _
"Beijing" & @CRLF & _
"Cairo" & @CRLF & _
"New York" & @CRLF & _
"Kolkata" & @CRLF & _
"Moscow" & @CRLF & _
"Bangkok" & @CRLF & _
"Buenos Aires" & @CRLF & _
"Shenzhen" & @CRLF & _
"Dhaka" & @CRLF & _
"Lagos"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")