$re = '/^[CM]/m';
$str = 'Tokyo
Jakarta
Delhi
Mumbai
Manila
Shanghai
Sao Paulo
Seoul
Mexico City
Guangzhou
Beijing
Cairo
New York
Kolkata
Moscow
Bangkok
Buenos Aires
Shenzhen
Dhaka
Lagos';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);