import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[CM]";
final String string = "Tokyo\n"
+ "Jakarta\n"
+ "Delhi\n"
+ "Mumbai\n"
+ "Manila\n"
+ "Shanghai\n"
+ "Sao Paulo\n"
+ "Seoul\n"
+ "Mexico City\n"
+ "Guangzhou\n"
+ "Beijing\n"
+ "Cairo\n"
+ "New York\n"
+ "Kolkata\n"
+ "Moscow\n"
+ "Bangkok\n"
+ "Buenos Aires\n"
+ "Shenzhen\n"
+ "Dhaka\n"
+ "Lagos";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}