$re = '/href="([^"\']+)"/';
$str = '<img class="alignnone size-full wp-image-15" src="http://wp491.dev/wp-content/uploads/2017/12/wordpress-speaker.png" alt="" width="1600" height="900" />
<a href="http://wp491.dev/wp-content/uploads/2017/12/pdf.pdf">pdf</a>
<a class="test" href="https://maximeculea.fr/wp-content/uploads/2017/12/pdf.pdf">pdf</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);