using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""([^""\']+)""";
string input = @"<img class=""alignnone size-full wp-image-15"" src=""http://wp491.dev/wp-content/uploads/2017/12/wordpress-speaker.png"" alt="" width=""1600"" height=""900"" />
<a href=""http://wp491.dev/wp-content/uploads/2017/12/pdf.pdf"">pdf</a>
<a class=""test"" href=""https://maximeculea.fr/wp-content/uploads/2017/12/pdf.pdf"">pdf</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}