#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "href="([^"\']+)""
Local $sString = "<img class="alignnone size-full wp-image-15" src="http://wp491.dev/wp-content/uploads/2017/12/wordpress-speaker.png" alt="" width="1600" height="900" />" & @CRLF & _
"" & @CRLF & _
"<a href="http://wp491.dev/wp-content/uploads/2017/12/pdf.pdf">pdf</a>" & @CRLF & _
"" & @CRLF & _
"<a class="test" href="https://maximeculea.fr/wp-content/uploads/2017/12/pdf.pdf">pdf</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")