package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`href="([^"\']+)"`)
var str = `<img class="alignnone size-full wp-image-15" src="http://wp491.dev/wp-content/uploads/2017/12/wordpress-speaker.png" alt="" width="1600" height="900" />
<a href="http://wp491.dev/wp-content/uploads/2017/12/pdf.pdf">pdf</a>
<a class="test" href="https://maximeculea.fr/wp-content/uploads/2017/12/pdf.pdf">pdf</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}