import Foundation
let pattern = #"(?'cislo_riadku'\d+)?[\t]?(?'nazov_polozky'[^\t]+)?[\t]?(?'pocet_kusov'\d+)?[\t]?(?'merna_jednotka'\w+)?[\t]?(?'jednotkova_cena'\d+\.\d+)?[\t]?(?'suma_bez_dph'\d+\.\d+)?[\t]?(?'dph'\d+%)?[\t]?(?'suma_s_dph'\d+\.\d+)?\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
14 Práce - 1NP - Rack "A" - skladové priestory LAN
15 motáž krabice do sadrokartónu 6 ks 6.000 36.00 20% 43.20
16 montáž žľabu 40/20 14 m 1.000 14.00 20% 16.80
17 montáž káblu FTP 1450 m 0.500 725.00 20% 870.00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)