import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'cislo_riadku'\\d+)?[\\t]?(?'nazov_polozky'[^\\t]+)?[\\t]?(?'pocet_kusov'\\d+)?[\\t]?(?'merna_jednotka'\\w+)?[\\t]?(?'jednotkova_cena'\\d+\\.\\d+)?[\\t]?(?'suma_bez_dph'\\d+\\.\\d+)?[\\t]?(?'dph'\\d+%)?[\\t]?(?'suma_s_dph'\\d+\\.\\d+)?\\n";
final String string = "14 Práce - 1NP - Rack \"A\" - skladové priestory LAN\n"
+ "15 motáž krabice do sadrokartónu 6 ks 6.000 36.00 20% 43.20\n"
+ "16 montáž žľabu 40/20 14 m 1.000 14.00 20% 16.80\n"
+ "17 montáž káblu FTP 1450 m 0.500 725.00 20% 870.00\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}