const regex = /(?'cislo_riadku'\d+)?[\t]?(?'nazov_polozky'[^\t]+)?[\t]?(?'pocet_kusov'\d+)?[\t]?(?'merna_jednotka'\w+)?[\t]?(?'jednotkova_cena'\d+\.\d+)?[\t]?(?'suma_bez_dph'\d+\.\d+)?[\t]?(?'dph'\d+%)?[\t]?(?'suma_s_dph'\d+\.\d+)?\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'cislo_riadku\'\\d+)?[\\t]?(?\'nazov_polozky\'[^\\t]+)?[\\t]?(?\'pocet_kusov\'\\d+)?[\\t]?(?\'merna_jednotka\'\\w+)?[\\t]?(?\'jednotkova_cena\'\\d+\\.\\d+)?[\\t]?(?\'suma_bez_dph\'\\d+\\.\\d+)?[\\t]?(?\'dph\'\\d+%)?[\\t]?(?\'suma_s_dph\'\\d+\\.\\d+)?\\n', 'g')
const str = `14 Práce - 1NP - Rack "A" - skladové priestory LAN
15 motáž krabice do sadrokartónu 6 ks 6.000 36.00 20% 43.20
16 montáž žľabu 40/20 14 m 1.000 14.00 20% 16.80
17 montáž káblu FTP 1450 m 0.500 725.00 20% 870.00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}