using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'cislo_riadku'\d+)?[\t]?(?'nazov_polozky'[^\t]+)?[\t]?(?'pocet_kusov'\d+)?[\t]?(?'merna_jednotka'\w+)?[\t]?(?'jednotkova_cena'\d+\.\d+)?[\t]?(?'suma_bez_dph'\d+\.\d+)?[\t]?(?'dph'\d+%)?[\t]?(?'suma_s_dph'\d+\.\d+)?\n";
string input = @"14 Práce - 1NP - Rack ""A"" - skladové priestory LAN
15 motáž krabice do sadrokartónu 6 ks 6.000 36.00 20% 43.20
16 montáž žľabu 40/20 14 m 1.000 14.00 20% 16.80
17 montáž káblu FTP 1450 m 0.500 725.00 20% 870.00
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}