import Foundation
let pattern = #"(?<Command>\/(?:.|\n(?:\t| +).)*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/run attribute 0 "Hello, World!" idNameWoo true [0, 0] minecraft:grass_block run time set 0
/multiline
attribute
0
"Hello, World!"
idNameWoo
true
[0, 0]
minecraft:grass_block
run time set 0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)