re = /(?<Command>\/(?:.|\n(?:\t| +).)*$)/m
str = '/run attribute 0 "Hello, World!" idNameWoo true [0, 0] minecraft:grass_block run time set 0
/multiline
attribute
0
"Hello, World!"
idNameWoo
true
[0, 0]
minecraft:grass_block
run time set 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end