const regex = /(?<Command>\/(?:.|\n(?:\t| +).)*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<Command>\\\/(?:.|\\n(?:\\t| +).)*$)', 'gm')
const str = `/run attribute 0 "Hello, World!" idNameWoo true [0, 0] minecraft:grass_block run time set 0
/multiline
attribute
0
"Hello, World!"
idNameWoo
true
[0, 0]
minecraft:grass_block
run time set 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}