// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)construit en (lieu|plusieurs|parpaings|face|forme|immeuble|(\d+|\w{2,10}) ([ée]tapes|phases)|ossature|siporex|plaques|charpente|rez.*|rdc|cloison|\d+ fois|r\+\d+)").unwrap();
let string = "[NE PAS TENIR COMPTE]
construit en lieu
construit en plusieurs
construit en parpaings
construit en face
construit en forme
construit en immeuble
construit en deux étapes
construit en ossature
construit en siporex
construit en plaques béton
construit en charpente
construit en rez-de-chaussé
construit en 2 phases
construit en cloison
construit en 3 fois
construit en r+1 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}