#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)construit en (lieu|plusieurs|parpaings|face|forme|immeuble|(\d+|\w{2,10}) ([ée]tapes|phases)|ossature|siporex|plaques|charpente|rez.*|rdc|cloison|\d+ fois|r\+\d+)"
Local $sString = "[NE PAS TENIR COMPTE]" & @CRLF & _
"construit en lieu" & @CRLF & _
"construit en plusieurs" & @CRLF & _
"construit en parpaings" & @CRLF & _
"construit en face" & @CRLF & _
"construit en forme" & @CRLF & _
"construit en immeuble" & @CRLF & _
"construit en deux étapes" & @CRLF & _
"construit en ossature" & @CRLF & _
"construit en siporex" & @CRLF & _
"construit en plaques béton" & @CRLF & _
"construit en charpente " & @CRLF & _
"construit en rez-de-chaussé" & @CRLF & _
"construit en 2 phases" & @CRLF & _
"construit en cloison" & @CRLF & _
"construit en 3 fois " & @CRLF & _
"construit en r+1 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")