using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"construit en (lieu|plusieurs|parpaings|face|forme|immeuble|(\d+|\w{2,10}) ([ée]tapes|phases)|ossature|siporex|plaques|charpente|rez.*|rdc|cloison|\d+ fois|r\+\d+)";
string input = @"[NE PAS TENIR COMPTE]
construit en lieu
construit en plusieurs
construit en parpaings
construit en face
construit en forme
construit en immeuble
construit en deux étapes
construit en ossature
construit en siporex
construit en plaques béton
construit en charpente
construit en rez-de-chaussé
construit en 2 phases
construit en cloison
construit en 3 fois
construit en r+1 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}