const regex = new RegExp('construit en (lieu|plusieurs|parpaings|face|forme|immeuble|(\\d+|\\w{2,10}) ([ée]tapes|phases)|ossature|siporex|plaques|charpente|rez.*|rdc|cloison|\\d+ fois|r\\+\\d+)', 'gm')
const str = `[NE PAS TENIR COMPTE]
construit en lieu
construit en plusieurs
construit en parpaings
construit en face
construit en forme
construit en immeuble
construit en deux étapes
construit en ossature
construit en siporex
construit en plaques béton
construit en charpente
construit en rez-de-chaussé
construit en 2 phases
construit en cloison
construit en 3 fois
construit en r+1 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}