import Foundation
let pattern = #"""
(20[0-9]{2}\-((?=0[1-9])0[1-9]|(?=1[0-2])1[0-2])
\-((?=0[1-9])0[1-9]|(?=[1-2][0-9])[1-2][0-9]|(?=[3][0-1])[3][0-1])
|(all))
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
2018-09-10
2018-11-20
2018-09-01
2018-12-01
ALL
2018-12-99
2018-99-20
2018-39-20
2018-39-39
2018-39-19
2018-00-99
9999-00-99
2000-00-99
2099-00-00
All
all
xxx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)