const regex = /(20[0-9]{2}\-((?=0[1-9])0[1-9]|(?=1[0-2])1[0-2])
\-((?=0[1-9])0[1-9]|(?=[1-2][0-9])[1-2][0-9]|(?=[3][0-1])[3][0-1])
|(all))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(20[0-9]{2}\\-((?=0[1-9])0[1-9]|(?=1[0-2])1[0-2])
\\-((?=0[1-9])0[1-9]|(?=[1-2][0-9])[1-2][0-9]|(?=[3][0-1])[3][0-1])
|(all))', 'gmi')
const str = `2018-09-10
2018-11-20
2018-09-01
2018-12-01
ALL
2018-12-99
2018-99-20
2018-39-20
2018-39-39
2018-39-19
2018-00-99
9999-00-99
2000-00-99
2099-00-00
All
all
xxx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}