import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(20[0-9]{2}\\-((?=0[1-9])0[1-9]|(?=1[0-2])1[0-2])\n"
+ "\\-((?=0[1-9])0[1-9]|(?=[1-2][0-9])[1-2][0-9]|(?=[3][0-1])[3][0-1])\n"
+ "|(all))";
final String string = "2018-09-10\n"
+ "2018-11-20\n"
+ "2018-09-01\n"
+ "2018-12-01\n"
+ "ALL\n\n"
+ "2018-12-99\n"
+ "2018-99-20\n"
+ "2018-39-20\n"
+ "2018-39-39\n"
+ "2018-39-19\n"
+ "2018-00-99\n"
+ "9999-00-99\n"
+ "2000-00-99\n"
+ "2099-00-00\n"
+ "All\n"
+ "all\n"
+ "xxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}