use strict;
my $str = '2018-09-10
2018-11-20
2018-09-01
2018-12-01
ALL
2018-12-99
2018-99-20
2018-39-20
2018-39-39
2018-39-19
2018-00-99
9999-00-99
2000-00-99
2099-00-00
All
all
xxx';
my $regex = qr/(20[0-9]{2}\-((?=0[1-9])0[1-9]|(?=1[0-2])1[0-2])
\-((?=0[1-9])0[1-9]|(?=[1-2][0-9])[1-2][0-9]|(?=[3][0-1])[3][0-1])
|(all))/mixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}